Complete
Maintenance has completed
In progress
Maintenance has started
Scheduled
CELESTIA-APP v8.0.2-arabica & CELESTIA-NODE v0.30.2-arabica — Arabica upgrade
Dear partners and node operators,
We are pleased to announce new versions of celestia-app and celestia-node today. Please upgrade as soon as possible to benefit from the latest fixes and improvements.
Celestia-app:
This release is intended for Arabica. If you are upgrading from v6 or v7, please read through the release notes carefully.
Bug fix: Resolved a data race condition in the signing context GetSigners method.
Monitoring: Added latency and failure metrics dashboards for Grafana.
Dependencies: Updated v3 multiplexer binary to version 3.12.0.
Documentation: Updated Ubuntu OS version requirements.
Release notes: https://github.com/celestiaorg/celestia-app/releases/tag/v8.0.2-arabica
Celestia-node:
This patch release improves P2P stability on Arabica by removing broken bootstrapper nodes that were causing peer discovery issues. It also includes a log level adjustment in the shrex-client to reduce noise in diagnostic output.
P2P fixes: Removed broken Arabica bootstrapper nodes to improve peer discovery reliability.
Logging: Adjusted log level in shrex-client for cleaner diagnostic output.
Release notes: https://github.com/celestiaorg/celestia-node/releases/tag/v0.30.2-arabica
Thank you,
Celestia Foundation