Mocha testnet has been upgraded successfully at height 8236886
In progress
MsgTryUpgrade submitted on Mocha testnet. An upgrade is pending to app version 6 at height 8236886.
In progress
CELESTIA-NODE v0.27.4-mocha — Mocha Upgrade
Dear partners and node operators,
We are pleased to announce a new version of celestia-node today. Please upgrade as soon as possible to benefit from the latest fixes and improvements.
Celestia-node:
This release includes a bug fix.
Release notes: https://github.com/celestiaorg/celestia-node/releases/tag/v0.27.4-mocha
Thank you,
Celestia Foundation
In progress
CELESTIA-NODE v0.27.3-mocha - Mocha upgrade
Dear partners and node operators, We are pleased to announce a new version of celestia-node today. Please upgrade as soon as possible to benefit from the latest features.
Celestia-node:
This release includes a bug fix.
Release notes: https://github.com/celestiaorg/celestia-node/releases/tag/v0.27.3-mocha
Thank you,
Celestia Foundation
In progress
CELESTIA-NODE v0.27.2-mocha and CELESTIA-APP v6.0.5-mocha - Mocha v6 Matcha upgrade
Dear partners and node operators, We are pleased to announce a new version of celestia-app and celestia-node today. Please upgrade as soon as possible to benefit from the latest features.
Celestia app:
This is a consensus and config breaking release to v6. This release targets throughput, blob size, inflation reduction, and fee changes.
Notable features and changes:
Changes to block propagation, block syncing and p2p layer that would enable up to 128MB/6s; increase max tx size to 8MB (max block size requires a governance vote)
Fixes the bug with using ICA and the bug with claiming rewards from a validator that used to be delegated to
Increases the minimum gas price from 0.002 to 0.004 utia
Decreases the unbonding period to 14 days and 1 hour
Removes the token filter
Decreases issuance to 2.5% and increases minimum validator commission to 10% (no governance vote required)
Requires nodes to update their config celestia-appd update-config . More info the release notes
Hardware Requirement changes: 32GB RAM, 16 CPUs and 2TB NVMe
⚠️ If you are using tmkms or horcrux please upgrade them from the following tmkms and horcrux repositories that Celestia maintains. If you are using a private/proprietary KMS, please see https://discord.com/channels/638338779505229824/1169241489776324608/1402654522354171965 and reach out to Evan. ⚠️
⚠️ If you are using Cosmovisor, please remove it before upgrading as it can lead to potential issues! ⚠️
If you are an active validator:
please signal to upgrade to v6: `celestia-appd tx signal signal 6 --from (validatorwallet) --chain-id mocha-4 --fees 210000utia`
you can track the tally of signaling by validators using the following query `celestia-appd query signal tally 6`
Once 5/6+ of the voting power have signaled, the upgrade will be ready.
There is a hard coded delay between confirmation of the upgrade and execution to the new state machine.
To view the upcoming upgrade height use the following query: `celestia-appd query signal upgrade`
The upgrade delay is 2 days after 5/6+ voting power has signaled and the upgrade tx is submitted
Release notes: https://github.com/celestiaorg/celestia-app/releases/tag/v6.0.5-mocha
Celestia-node:
This release corresponds to the v6 upgrade and is a config breaking release. Please see here on how to update your config.
This release includes changes necessary for celestia-app v6 compatibility. It also reduces the storage window from 30 days to 7.
If bumping directly from v0.25.x-mocha to this release, please see release notes for v0.26.2-mocha that contain important changes + features.
⚠️ Please be aware of hardware requirement changes here. ⚠️
Release notes: https://github.com/celestiaorg/celestia-node/releases/tag/v0.27.2-mocha
Release timeline:
The v6 Matcha upgrade for Mocha testnet has an updated release timeline:
Thursday 25th September: Core/app and node cut -mocha releases for v6.
Thursday 25th - Sunday 28th: Signaling period
Monday 29th: Submit MsgTryUpgrade
Wednesday 1st October: Mocha network upgrades from v5 - v6.
Thank you,
Celestia Foundation
Scheduled
The v6 Matcha upgrade for Mocha testnet has a new release timeline:
Thursday 25th September: Core/app and node cut -mocha releases for v6.
Thursday 25th - Sunday 28th: Signaling period
Sunday 28th: Submit MsgTryUpgrade
Tuesday 30th: Mocha network upgrades from v5 - v6.
Scheduled
The v6 Matcha upgrade for Mocha testnet has a new release timeline:
Wednesday 24th September: Core/app and node cut -mocha releases for v6.
Wednesday 24th - Friday 26th: Signaling period
Saturday 27th: Submit MsgTryUpgrade
Monday 29th: Mocha network upgrades from v5 - v6.
Scheduled
The v6 Matcha upgrade for Mocha testnet has a new release timeline:
Tuesday 23rd September: Core/app and node cut -mocha releases for v6.
Wednesday 24th - Friday 26th: Signaling period
Saturday 27th: Submit MsgTryUpgrade
Monday 29th: Mocha network upgrades from v5 - v6.
Scheduled
Wednesday 17th Sept: Core/app and node cut -mocha releases for v6.
Wednesday 24th - Friday 26th: Signaling period
Saturday 27th: Submit MsgTryUpgrade
Monday 29th: Mocha network upgrades from v5 - v6.